My access token of facebook graph API expired today. My facebook graph api accrss token has upgrade to v2.6 in facebook developer 2.6. But the facebook-sdk in my server olny support to v 2.5 and I saw the following error message “Valid API versions are ‘2.0’, ‘2.1’, ‘2.2’, ‘2.3’, ‘2.4’, ‘2.5’”. I fix this problem with following steps.

  • Open https://developers.facebook.com/apps/ and choice my APP to check api version

螢幕快照 2016-11-17 上午6.41.08

  • Click “Tool and Support” -> click  “Access Token” -> click  “Debug” enter  access token  detail information -> Click “Extend Access Token” get new available access token

螢幕快照 2016-11-17 上午6.47.48

螢幕快照 2016-11-17 上午6.51.15

  • Upgrade my server facebook-sdk
    • pip install facebook-sdk –upgrade
  •  Update new access token and API version and task works.